New link in the top of page "IRC Chat".
Register | Login
Views: 59849401
Main | Memberlist | Active users | Calendar | Last Posts | IRC Chat | Online users
Ranks | FAQ | XPW | Stats | Color Chart | Photo album
06-26-17 09:48 AM
0 users currently in General Chat.
Xeogaming Forums - General Chat - That login issue bug | |
Next newer thread | Next older thread
User Post
Cammygirl192

Wall Crab








Since: 08-15-15
From: England

Since last post: 272 days
Last activity: 270 days
Posted on 02-20-16 03:06 PM Link | Quote
I'm browsing the accounts created (mostly spam) and it seems they have the exact same login issue here that I have on this board.

Usually spambots' last view will match exactly with their last post on the site, and sometimes later, but it seems all accounts registered after mine (at the least) have broken login.

I already tried the different URLs and www but it doesn't work, I also tried using a proxy which also doesn't work, there's something glitched in your systems, probably something to do with your host.
Xeoman

Vire
Administrator








Since: 08-14-04
From: 255

Since last post: 20 hours
Last activity: 1 hour
Posted on 02-22-16 07:56 PM Link | Quote
I've reached out to our coder admin to see if he knows what's up with this.
Cammygirl192

Wall Crab








Since: 08-15-15
From: England

Since last post: 272 days
Last activity: 270 days
Posted on 02-24-16 01:26 PM Link | Quote
If you try to make a poll you'll get PHP errors once you have one more option.
It doesn't do any shit effects though.

It seems the issue appeared about 6 months before the account 'Luigi442wii' was registered, which could mean it's something to do with PHP itself breaking since AcmlmBoard is old software.

If you see an account called 'Cammy' registered then that will just be my test account for see whether it's logged in properly.
Kard Ayals
The Ultimate
Lv101
Posts2888
Counter2
Mv7Jm26
Hp2189/2189
Sp709/709
Atk361 Int279
Def389 Spd281
Hit254 Res275
Exp10520262
Next197413
Banhammer
Shining Armor
Admin Shield
Judge Hat
Admin Shoes
POWAR

Posted on 02-29-16 08:29 PM Link | Quote
Originally posted by Termingamer2-JD
It seems the issue appeared about 6 months before the account 'Luigi442wii' was registered, which could mean it's something to do with PHP itself breaking since AcmlmBoard is old software.



That's about right. Happened a bit earlier than that, but it's pretty close.

It should work correctly now.
Cammygirl192

Wall Crab








Since: 08-15-15
From: England

Since last post: 272 days
Last activity: 270 days
Posted on 03-01-16 11:45 AM Link | Quote
Thanks for fixing it!
What exactly were the issues caused with the system at that time, though? Feel free to share any code snippets.

Also, somebody please change my username to Cammygirl192 if possible, although I don't want anything breaking due to that XD
Kard Ayals
The Ultimate
Lv101
Posts2888
Counter2
Mv7Jm26
Hp2189/2189
Sp709/709
Atk361 Int279
Def389 Spd281
Hit254 Res275
Exp10520262
Next197413
Banhammer
Shining Armor
Admin Shield
Judge Hat
Admin Shoes
POWAR

Posted on 03-01-16 03:52 PM Link | Quote
No snipets, but more or less what happened:
- Acmlmboards used to store data as md5 only
- At some point I get fed up and changed that to something more modern (i.e.: add salts and don't use md5)
- I run a script to populate the salts for all existing users, stored hashes are converted to the new way upon first successful login.

- For new users, storage is done the new way from the beginning, but salts weren't generated (which I swear I did do, so it probably never went live).
- The way the credentials are verified when logging in is slightly different from the way it is done on normal pages: the login would be accepted but then invalidated as soon as a page transition occurs.

All in all, a very stupid error.
Cammygirl192

Wall Crab








Since: 08-15-15
From: England

Since last post: 272 days
Last activity: 270 days
Posted on 03-01-16 11:41 PM Link | Quote
Haha I understand yeah it does seem a stupid error but we learn from them
Thanks. And yeah, md5 isn't good anymore.

Also how did suddenly my layout viewing is set to nothing? It's changed now.


(Last edited by Cammygirl192 on 03-01-16 11:43 PM)
Next newer thread | Next older thread
Xeogaming Forums - General Chat - That login issue bug |



xeogaming.org

AcmlmBoard 1.92++ r4 Baseline
?2000-2013 Acmlm, Emuz, Blades, Xkeeper, DarkSlaya*, Lord Alexandor*
*Unofficial Updates
Page rendered in 0.213 seconds.