New link in the top of page "IRC Chat".
Register | Login
Views: 61957585
Main | Memberlist | Active users | Calendar | Last Posts | IRC Chat | Online users
Ranks | FAQ | XPW | Stats | Color Chart | Photo album
10-22-17 09:43 AM
0 users currently in General Chat.
Xeogaming Forums - General Chat - That login issue bug
  
User name:
Password:
Reply:
 
Options: - -
UserPost
Cammygirl192
Posts: 101/199
Haha I understand yeah it does seem a stupid error but we learn from them
Thanks. And yeah, md5 isn't good anymore.

Also how did suddenly my layout viewing is set to nothing? It's changed now.
Kard Ayals
Posts: 2888/2888
No snipets, but more or less what happened:
- Acmlmboards used to store data as md5 only
- At some point I get fed up and changed that to something more modern (i.e.: add salts and don't use md5)
- I run a script to populate the salts for all existing users, stored hashes are converted to the new way upon first successful login.

- For new users, storage is done the new way from the beginning, but salts weren't generated (which I swear I did do, so it probably never went live).
- The way the credentials are verified when logging in is slightly different from the way it is done on normal pages: the login would be accepted but then invalidated as soon as a page transition occurs.

All in all, a very stupid error.
Cammygirl192
Posts: 98/199
Thanks for fixing it!
What exactly were the issues caused with the system at that time, though? Feel free to share any code snippets.

Also, somebody please change my username to Cammygirl192 if possible, although I don't want anything breaking due to that XD
Kard Ayals
Posts: 2887/2888
Originally posted by Termingamer2-JD
It seems the issue appeared about 6 months before the account 'Luigi442wii' was registered, which could mean it's something to do with PHP itself breaking since AcmlmBoard is old software.



That's about right. Happened a bit earlier than that, but it's pretty close.

It should work correctly now.
Cammygirl192
Posts: 88/199
If you try to make a poll you'll get PHP errors once you have one more option.
It doesn't do any shit effects though.

It seems the issue appeared about 6 months before the account 'Luigi442wii' was registered, which could mean it's something to do with PHP itself breaking since AcmlmBoard is old software.

If you see an account called 'Cammy' registered then that will just be my test account for see whether it's logged in properly.
Xeoman
Posts: 11011/11501
I've reached out to our coder admin to see if he knows what's up with this.
Cammygirl192
Posts: 84/199
I'm browsing the accounts created (mostly spam) and it seems they have the exact same login issue here that I have on this board.

Usually spambots' last view will match exactly with their last post on the site, and sometimes later, but it seems all accounts registered after mine (at the least) have broken login.

I already tried the different URLs and www but it doesn't work, I also tried using a proxy which also doesn't work, there's something glitched in your systems, probably something to do with your host.
Xeogaming Forums - General Chat - That login issue bug



xeogaming.org

AcmlmBoard 1.92++ r4 Baseline
?2000-2013 Acmlm, Emuz, Blades, Xkeeper, DarkSlaya*, Lord Alexandor*
*Unofficial Updates
Page rendered in 0.110 seconds.